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Block Filling

A British-style puzzle, in which words are linked every alternate letter, has a regular pattern of 
blocks. The basic pattern can be filled in quickly by choosing Fill Blocks from the Pattern 
menu.

Block filling fills in every alternate block on alternate rows. There are four choices of starting 
position:

Fill from (1,1): Fill from (2,1):

Fill from (1,2): Fill from (2,2):

Note that fill from (2,1) and (1,2) is not compatible with dual-symmetry.



Symmetry

You can automatically create a symmetric pattern by selecting one of the symmetry options from 
the Pattern menu. You can have normal S-Symmetry or Dual-Symmetry (Dual-Symmetry only 
works if you have a square puzzle).

This pattern shows Dual-Symmetry:

    

Whereas this one only has S- Symmetry:

    



Autofind

Autofind can be used to find words to fit in the puzzle. Select Autofind from the Words menu, 
or click the right mouse button on a square in the word. Words are found to fit in the current type
direction, but if there is only one possible word through the cursor's square, words are found to 
fit there.

For example if you had a puzzle that looked like this:

You may want to find a word to fit down the middle. Click with the right mouse button on one of
the squares, for example, above the 'D', and a scrollable list of words that fit is produced. Simply 
scroll through and select the word you want and press Insert. If you selected the word    
ADMIRAL then the puzzle would look like this:

Note that compound words in the word list are not punctuated, eg. 'OUT OF DATE' appears as 
'OUTOFDATE', as it will in the puzzle.

To find a word to fit a given template use the Find Word... command on the Words menu. To 
find a fit for whole sections of the puzzle rather than just one word at a time us the Fill 
Automatically command on the Words menu.



Find Words

If you want to find words that match a specific pattern you can use the Find Word... command 
on the Words menu.

In the dialogue box enter the template for the word, using '?' for letters you don't know. Eg. to 
find a 5 letter word that starts in 'T' and ends in 'ND' enter 'T??ND', and the program will find all 
the words in the lists which match (eg. 'TREND').

If you want to find words to fit in the puzzle it is easier to use the Autofind facility.



Puzzle Flipping

A puzzle may be flipped to its mirror image by selecting Flip Pattern from the Pattern menu. 
This has not effect other than the numbering and order of the clues, and the appearance of the 
puzzle. A flip can be undone by doing another flip. Here is a puzzle, one before and one after a 
flip:



Font

You may change the font used to display and print the puzzle and clues by selecting Font... from 
the Options menu. You can only use True Type fonts with Crossword Compiler. The point size 
you choose has no effect on the puzzle but is used in Printing the clues. Here is what a sample 
puzzle looks like with some of the standard fonts:

Arial: Arial Bold:

Courier New: Times New Roman:



Anagram

You can search for multiple word anagrams of a given word, either from the Clue Editor or by 
choosing Anagram... from the Words menu.

If you run it from the Clue Editor the word you are clueing will be anagrammed automatically. If
you choose Anagram... from the menu you should enter the word in the dialogue box. If you 
wish to anagram for multiple words just enter the words you want to anagram.

Anagram finds all the multiple word anagrams of the given word up to a certain number of 
letters. The maximum number of words in the multi-word anagram can be specified in the 
Defaults dialogue box. If you choose a large number the search is slower as there will be a lot of 
different anagrams. Specifying a small number also makes it easier to find a suitable anagram.

Anagrams are displayed as they are found. The words in multi-word anagrams are not sorted, but
anagrams are found in order of word length, so you should get all the straight anagrams before 
the multi-word ones etc.

The Search can be aborted at any time by pressing OK. Anagrams are added to the bottom of the 
list as they are found. If there are a lot of possible anagrams they may not all be found, but you 
should always get at least the first thousand or so. The finder will work in the background as you 
edit other clues or whatever. To bring the window to the top just click on it. You can leave the 
anagram window open, and it will be reset with a new word whenever you select Anag... in the 
clue editor, or New in the anagram window. Anag... sets the word to the word you are clueing, 
New prompts you for a new word to anagram.



Changing Square Sizes

The size at which the puzzle and solution are displayed, printed, and copied to the clipboard can 
be customised. Select Square Sizes... from the Options menu to bring up a dialogue box.

Puzzle    - Specifies the size in millimetres of the puzzle used in printing and the suggested 
puzzle size when it is copied to the clipboard. 

Solution    - Size in millimetres of the solution.

Zoom % of puzzle size    - Specifies the factor by which the puzzle size is enlarged when you 
edit it on the screen. This does not effect the printed size.



 Editing the Puzzle

When you start a New puzzle, or Open an existing one, the puzzle is displayed in the window 
with a cursor in the top right hand corner.

You enter letters from the current cursor position by typing as normal. Black squares (blocks) are
inserted by pressing the space bar. In the puzzle there are usually words going in two directions, 
to change the direction of typing press tab, or click on the direction icon on the Toolbar. This 
then displays the current type direction. The cursor also changes to show the type direction:

          To type Horizontally

          To type Vertically

You can use the cursors to move round the puzzle, or click with the left mouse button to move to 
a certain square. You can also insert blocks by double clicking with the left mouse button.

For a full list of keyboard commands see Keyboard.

You can fill in some of the pattern by using the Fill Blocks command on the Pattern menu.

To automatically insert blocks in symmetrical positions select one of the Symmetry options on 
the Pattern  menu.

You can create irregular puzzles by removing unwanted squares from the puzzle. Press 
Ctrl+Delete with the cursor on the square to be removed. To remove all blank squares from the 
puzzle, select the Remove Blanks command from the Pattern  menu. This makes the puzzle only
have lines around squares with letters or blocks in, so giving it an irregualar outline.

 You can Undo editing by pressing Alt+Delete. This moves the cursor to the end of the last 
editing action and then undoes the action. This can be repeated a large number of times to undo 
chunks of the puzzle. Interlocking letters are not removed using Undo, so leaving the 
intersecting words intact. Undo is particularly useful with Autofind to test words in certain 
positions and then undo them if necessary.



Giving the puzzle a reference

You can give a reference to a puzzle in addition to its file name by selecting Reference... from 
the File menu. Enter anything you want, typically information about who wrote the puzzle, when
etc. It has no effect other than to give some extra information about the puzzle, and it can be 
printed when you Print the puzzle.



Copying to the clipboard

You can copy the puzzle, clues, solution or answers to the clipboard to use them in other 
Windows programs. Select Copy to clipboard... from the file menu, and select what you want 
copied.

 The puzzle and solution are copied as pictures (metafiles) that can be resized in the host 
application. They are copied by default at the size specified in the Square Sizes dialogue box, 
but can then be resized without any loss in quality.

    The clues and answers are copied as Rich Text Format (RTF) and plain text. The host 
application will use the appropriate format. Most word processors (but NOT Write) and DTP 
programs will accept RTF, which gives formatted text, bold clue numbers right aligned etc. Other
programs can use the plain text, but it won't look as good. 

    The space between clues, and the space between the clue number and the clue can be 
customised in the Format dialogue box for RTF. The relative size of the numbers in the puzzle 
can also be changed. The font in the puzzle and solution is set in the Font dialogue box, the font 
for the clues and answers is set by the host program so it will match the font you are using in 
that. If you find that the clues do not copy correctly then try increasing the Number/Clue space in
the format dialog box.

The answers option copies the answers in text form eg.

Across: 1 Cueing, 4 Abbott, 9 Infant prodigy, 10 Connoisseurs, 12 Alcove, 14 Shinto, 16 
Overdecorate, 19 Command module, 20 Donate, 21 Oyster.
Down: 1 Chitchat, 2 Elfin, 3 Non-conversant, 5 Biotechnology, 6 Omicron, 7 Toys, 8 Spasm, 11 
Forebear, 13 Cavemen, 15 Bendy, 17 Adult, 18 Scud. 

The solution option copies the completed puzzle, as it looks when you edit it, eg.

      

The clues and answers can then be put into columns or whatever in the host program.



Reviewing the Clues

    You can view the clues written so far using the Review Clues... command in the Clue menu. 
The clues are shown in two scrollable lists, with the clue number at the left, and the solution to 
the right. If a word is unclued the clue reads 'No Clue'. If    there are incomplete words in the 
puzzle the solution appears with question marks for the missing letters. 

      You can edit a clue by selecting the clue by scrolling through the lists and pressing the Edit 
button (Alt+E), or double clicking on the clue with the left mouse button. This brings up the 
Clue Editor dialogue box which you can use normally. You can move between the Across and 
Down clues using Tab and Shift+Tab.

It is a good idea to review the clues before you Print them to check you haven't missed any 
clues, or that any words are incomplete. It also makes quite a convenient way to edit the clues.



Keyboard

Keyboard controls when editing puzzle:

CURSORS Move the cursor

CTRL+CURSORS Skip to next or previous word start

TAB Toggle type direction

ENTER Move to left or top of next line

SPACEBAR Insert Block

DELETE Delete letter/block at cursor

CTRL+DELETE Remove square from puzzle

SHIFT+DELETE Delete word. Doesn't effect intersecting words

ALT+BACKSPACE,
CTRL+U Undo

ALT+A Autofind 

ALT+E Edit Clue 

F1 Help Index

F2 Save

CTRL+ESC Switch to another program

See Mouse for mouse combinations and the Toolbar topic



Mouse

Left Button Move cursor to square clicked on

Double Left Button Insert block in square clicked on

Right Button Autofind words to fit in word clicked on

See Keyboard for keyboard shortcuts, and the Toolbar topic.



Open and existing file

    You can open an exisiting crossword file by selecting Open... from the File menu.
Enter the name of the file to open, or select the directory and file from the list boxes and press 
Open. If you have an unsaved puzzle already open you will be prompted to ask if you want to 
save it or not before opening the new puzzle.

Crossword Compiler puzzle files have the .CWD extension, and are in a special format, you 
cannot open files saved by another application.



Starting a new crossword

    You can start a new crossword with a blank grid by selecting New from the File menu.
You are prompted for the size of the puzzle you want to create. Valid sizes are between 3 and 39 
squares height and width. If you have an unsaved puzzle already open you will be prompted to 
save it.



Saving a puzzle with a name

You can give a puzzle a name, or save under a new name by selecting Save As... from the File 
menu. Enter the name for the puzzle and press OK. You can select a different directory by using 
the list box on the right.
 You can save the puzzle as a .CWD file for further editing with Crossword Compiler, or as Rich 
Text Format, to use in other applications. Change the selection in the Save file as type input box 
to change the setting and give the file a name ending in '.RTF' Puzzles saves as Rich Text Format
(RTF) with the .RTF extension cannot be reopened from Crossword Compiler, but does allow 
you to save the puzzle clues etc. so that they can be used in word processing, DTP programs etc. 
If you save as RTF you are prompted for what you want saved in the file, the puzzle, clues, 
solution, answers or a combination.

You can save a puzzle as a .CWD file with its present name by pressing F2 or selecting Save 
from the File menu.



Save

Select Save from the file menu or press F2 to save the puzzle with its present name. If the puzzle
is un-named the Save As dialogue box will open for you to choose a name.



Printer Setup

Select Printer Setup... from the File menu to select and setup a printer for Printing. Select the 
printer you want from the drop down list. You can press the Setup... button to set other options 
such as page orientation, size etc.



Toolbar

The toolbar is the array of icons at the to of the program window. By clicking on them with the 
mouse you can quickly invoke the command they represent. This is what they do:

      Get Help

Open an existing file

Save the crossword

    Invoke Autofind 

Fill Automatically from cursor

Toggle type direction 

Undo last change. Can be used multiple 
times.

Edit Clue

See Editing the Puzzle for more information on undoing    and type directions.



Writing Clues

You can edit the clue for a particular word in the puzzle by pressing Alt+E with the cursor on the 
word of the clue you want to edit, or by using the Edit tool on the Toolbar. If there are two words
through the letter at the cursor, it will select the word in the current type direction. A dialog box 
will pop up in which you enter the clue. Once you have finished the clue press Enter to close the 
dialog box or Alt+> to edit the next clue. The number of the clue is displayed in the title bar of 
the dialog box and the word the clue is for is displayed below. There is a large input box for 
entering the clue and an input line for entering the format of the word.

Here's a summary of clue dialog box commands, which can also be called by clicking with the 
mouse on the buttons at the top of the dialog box:

 Enter Close editor, saving changes
 ESC Close editor without saving changes
 Alt+D Delete the clue
 Alt+> Move to next clue, saving changes
 Alt+< Move to previous clue, saving changes
 Alt+K Link the clue
 Alt+U Update the box, eg if you have changed

the puzzle or the word format
 Alt+H or F1 Bring up this help screen
 
I suggest that you complete the puzzle network before starting to write clues, so then you can 
systematically write each clue in order with no chance of missing a clue or writing a clue for a 
word which will be changed later. Once you have finished you can review the clues by selecting 
Review Clues from the Clue menu.

 Editing the Clue

To edit the clue, or write a new one, simply type the clue in the Clue editor box. The editor word-
wraps the clue as you type so there is no need to press Enter to end a line, and the clue will then 
be correctly wrapped when it is printed as well. The clue can be of any length up to a maximum 
of 400 characters, which should be long enough for anyone's purposes. The cursor can be moved 
within the editor box using the cursor keys, or by clicking with the mouse. You can skip to the 
next word using Ctrl-Right or the last word with Ctrl-Left.

You can change the format of the solution by entering the format in the Word Format input line.



 Word Format - Automatic Word length

Do not include the length of the clue in the clue editor, but in the Word Format input line. By 
default this is just the number of letters in the word, which is entered automatically. However if 
the 'word' is in fact hyphenated or more than one word you can enter the format here. Just type 
the number of letters in each word, or hyphened half word, and a comma to indicate a new word 
or a hyphen to indicate a hyphen. The format is then automatically included in brackets at the 
end of the clue when it is printed, and the word is correctly formatted in the dialog box and if 
you print the answers.
For example if the word is displayed as ONTOPOFTHEWORLD (On top of the world), then in 
the format line type '2,3,2,3,5'. On pressing tab or Alt+U to update, the correctly formatted word 
will appear at the top of the dialog box. If the clue is linked then the format should be entered for
the linked solution.



 Printing the Crossword

Select Print... from the File menu to print the crossword. A dialog box is displayed showing the 
various print options. Check the check boxes for what you want printed. 'Puzzle' just prints the 
blank numbered puzzle as it would appear in a newspaper. You can also print the solution with 
the words in.
 
You can choose to print just the clues, in which case they are printed word wrapped in two 
columns, or you can print the clues with answers - word wrapped clue on the left and the 
solutions on the right (as when you review the clues).

Note that very large puzzles may not fit on A4 paper. If not you will be asked whether the square 
sizes you have chosen should be shrunk to make it fit. To change the margins choose the Page 
Setup... command    from the File menu. The printer can be changed by selecting Printer Setup... 
on the File menu.

Printing the puzzle uses all the settings set in the various Options dialog boxes.
See Square Sizes , Font and    Format for more information.



 Changing Default Settings

The directories in which the word files are kept should be set correctly before you use the 
Autofind, Find Word, AutoFill or Anagram facilities. These will probably be set up correctly if 
you have Crossword Compiler installed to the C:\CCW directory.

Selecting Defaults.. under the Options menu allows you to set and change the word file 
directory settings. The word files supplied with the program are called WORDS.X3,WORDS.X4
etc. To set the word files' directory, enter the root name and directory in the input line. So, for 
example, if the WORDS.X?? files are in the C:\MYWORDS directory then you would enter C:\
MYWORDS\WORDS. The complete set of the files with the given root should be in    the given 
directory otherwise you will get an error when searching for words of certain lengths. By default 
the SHORTS.X?? word list is used for Automatic Filling, as it contains less obscure words, 
and far fewer parts of speech than the WORDS word list. You can if you wish set the words used 
for anagrams and word finding to the SHORTS word list if you only want to use more common 
words, and few plurals etc.

You can also change the default puzzle size, so if, for example, you always produce 13x13 
puzzles you could change the default settings so that you do not need to change the size settings 
when you start a new crossword. You may also change the default Symmetry setting.

The maximum number of words found by Autofind can also be altered. Specifying
a very large number may slow down the search considerably, and a huge list of words
is not very helpful. Suggested numbers are in the range of hundreds or a couple of
thousands. Specifying a small number would probably only increase the search
speed significantly on a very slow computer. Larger figures are recommended as
you can then scroll through the list so that your puzzle does not end up with all its
words beginning with 'A'.

The maximum number of words in multi-word anagrams found by the Anagram facility can also 
be changed. Numbers larger than 3 or 4 will tend to make the search slow and produce vast 
numbers of anagrams for long words.

Settings in the Defaults... box are saved automatically when you quit the program.



Linking Clues

It is possible that you have two or more words in the crossword for which you wish to write a 
combined clue. For example, if somewhere in the puzzle there are the two words PREGNANT 
and PAUSE you may wish to write one clue for the phrase 'PREGNANT PAUSE' rather than two
separate clues. To do this bring up the Clue Editor with the cursor on the word 'PREGNANT'. 
Press Alt+L, or click with the mouse on the Link button at the top of the dialog box. Enter the 
number(s) of the clues to link to (the number of the clue is displayed at the top of the dialog box 
when you edit the clue). In the example above, 'PREGNANT' may for example be 1 Across, and 
'PAUSE' 5 Across. To link the two simply enter '5' in the input line and press Enter. The word at 
the top of the editor dialog box will now be PREGNANTPAUSE, and to format this correctly 
you should enter '8,5' in the Word Format    input line. 

From now on these two words will be linked, and if you select Edit Clue with the cursor on 
'PAUSE' it will automatically show you the clue you have written for 'PREGNANT PAUSE'. If 
you Print the puzzle 5 Across will have the clue 'See 1', and 1 Across will have the linked clue. If
you print the answers the linked word will be printed after 1 Across and not after 5 Across. If at 
some point you change the puzzle layout so that 'PAUSE' is no longer 5 Across but, say, 7 Across
the linking will still be done correctly.

You can link more than two words by entering the clue numbers you want linked separated by '/'. 
Do not enter the number of the clue you are editing, but just the clues you want linked to the end 
of it. You must be editing the first clue in the link so that you get the words linked in the correct 
order. Links can only be done on words in the same direction. To try to link clues that are already
linked would be an error as you can only link a given word once.

Note that pressing OK in the Link dialog box saves the clue as it is when you close the box, and 
that the link will not be undone if you Cancel the clue editor box after making a link. To remove 
a link bring up the Link dialog box and press delete to clear the input line. There will then be no 
links, and the clues of the words which were linked will be returned to the state they were in 
before the link was made.



Registering Crossword Compiler

This program is distributed as Shareware. You may use the program for a maximum of 30 days 
for evaluation. If you wish to use the program after this period you must register it. Registration 
costs only £25 including P&P for EEC, and £27 for other countries. A registration form is 
provided in the REGISTER.WRI file, and can be printed out by pressing Alt+R when at the 
program start-up screen, entering your details and printing the form. 

Otherwise send a cheque or PO/International Money Order (sorry, I can't take credit cards) to
Antony Lewis, 16 Townley Rd, London SE22 8SR, England.

Registered uses get the latest version of the program, with word lists for 3 to 20 letters, including
compound words upto 15 letters. The registered version also has facilities for adding and 
removing words from the word lists. The registering nag at program start up is also removed. It 
comes with an installation program to set it all up for you.

You may also buy some additional word lists at 5 UK pounds each.
The files are in two forms. Word files, which can be used directly like the original word lists, and
Merge files, which can be used to supplement one of the larger files. A utility is also provided for
converting Word files into Merge files so that the larger lists can also be merged together.

The sets are as follows:

174000+ Unusual words and variant spellings all in one word file

117000+ Expressions, literature, armaments & Old Testament. 

Mostly one large word file of expressions, with the 3 others as merge files.

176000+ Place names, Latin, Greek, German, Spanish, French and Jewish.

Word files of Latin, German and US place names, with the other files as merge files (including 
cities and UK place names).

UK Advanced crossword dictionary loads of words in one word file



Format

    They layout of the puzzle and clues when printed or copied to the clipboard can be changed by 
selecting Format... from the  Options menu.

Spacings

These specify the gap left between the number of the clue and the clue itself, and the vertical 
space between different clues when printed or copied. If you have problems copying clues to the 
clipboard, or opening a file save as Rich Text Format you could try increasing the value of the 
number/clue space as some programs don't like small measurements.

Size % of Squares

Here you can change the relative size of the squares and the numbers, the letters and the lines. 
Give a value in terms of the percentage of the Square Size. These ratios will then be preserved if 
you change the square sizes, or change the size once copied into another application.

Across/Down

Specify whether you want the Across and Down titles for the clues capitalised or centred.

Print Clues in Roman

Check this box to print the clues in Times New Roman font, regardless of the setting in the Font 
dialog box. Otherwise the same font is used for the clues as for the puzzle.

All changes in this box are saved automatically when you quit the program.
See Page Setup for changing the margins.



Information

For statistics and file information about a crossword select the Information... item on the File 
menu.

Labels in box are self explanatory.



Removing Blanks

To remove all squares in the puzzle with no letter or block in, select the Remove Blanks  item on
the Pattern menu.

Removing blanks gives the puzzle an outline that goes round every filled square, allowing you to
create free-form puzzles. A square can be toggled between being removed and blank by pressing 
ctrl+delete with the cursor on the square to be toggled. Here is an example of a puzzle before and
after removing the blanks:



Page Setup

Select Page Setup... from the File menu to change the margins used when the puzzle is printed.

All measurements are in centimetres.



Filling the Puzzle Automatically

 You can fill in complete puzzles, or sections of puzzles from a word list using the Fill 
Automatically command on the Words menu. You can also click on the AutoFill icon in the 
Toolbar.

 AutoFill attempts to fill in all non-complete words connected with the word the cursor is in. 
Place the cursor in a square in the section you want to fill, or place it in a blank square at the top 
of the grid to fill a blank puzzle. You need to have your array of black squares finalised before 
invoking AutoFill, which then fills round the blocks you have. It is designed to work with British
style puzzles, and will not really work on American style ones.

For example, if you had a crossword that looked like this:

you could place the cursor next to the 'E' in 'STICKER', and invoke AutoFill, to get a complete 
crossword. For example

Where there is a choice of words that will fit, one is chosen at random. By pressing 
Alt+Backspace to undo one fill, and invoking AutoFill again, you may be able to produce many 
different fits.

    AutoFill uses the word files specified in the AutoFill    files' path and name input line in the 
Defaults dialog box. By default these are the SHORTS word list, which is much shorter than 
the full WORDS word list, and contains words more likely to be acceptable in a crossword, 
rather than an exhaustive list of 'all' words.

While the computer is searching, words that it is trying are shown in the puzzle. The program 
actually looks 1 to 2 levels deeper than is displayed, but it gives you some idea    of the progress 
that it is making. You can cancel or stop the search at any time by pressing the buttons on the 
dialog box which pops up. There is a beep when the search is complete.




